Używam biblioteki local_auth: 0.4.0+1 w moim trzeprzewowym projekcie, ponieważ potrzebuję tego Uwierzytelnianie odcisków palców, problem polega na tym, kiedy uruchomię to ostrzeżenie:

*********************************************************

WARNING: This version of local_auth will break your Android build if it or its dependencies aren't compatible with AndroidX.
         See  for more information on the problem and how to fix it.
         This warning prints for all Android build failures. The real root cause of the error may be unrelated.    
         *********************************************************

A następnie to nastąpi:

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:processDebugResources'.
 Android resource linking failed
  Output:  C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:328: error: resource android:attr/fontVariationSettings not found.
  C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:328: error: resource android:attr/ttcIndex not found.
  error: failed linking references.

  Command: C:\Users\emami\.gradle\caches\transforms-1\files-1.1\aapt2-3.2.1-4818971-windows.jar\8e7abbb87897c27c7928ae79da9182a2\aapt2-3.2.1-4818971-windows\aapt2.exe link -I\
          C:\sdk\platforms\android-27\android.jar\
          --manifest\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\merged_manifests\debug\processDebugManifest\merged\AndroidManifest.xml\
          -o\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\processed_res\debug\processDebugResources\out\resources-debug.ap_\
          -R\
          @C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\incremental\processDebugResources\resources-list-for-resources-debug.ap_.txt\
          --auto-add-overlay\
          --java\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\generated\not_namespaced_r_class_sources\debug\processDebugResources\r\
          --custom-package\
          com.example.flutterapp\
          -0\
          apk\
          --output-text-symbols\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\symbols\debug\R.txt\
          --no-version-vectors
  Daemon:  AAPT2 aapt2-3.2.1-4818971-windows Daemon #0
  Output:  C:\Users\emami\.gradle\caches\transforms-1\files-1.1\design-27.1.1.aar\2118f8390bba553635fd03361d6fcc0d\res\values\values.xml:96:5-202: AAPT: error: resource android:attr/fontVariationSettings not found.

  C:\Users\emami\.gradle\caches\transforms-1\files-1.1\design-27.1.1.aar\2118f8390bba553635fd03361d6fcc0d\res\values\values.xml:96:5-202: AAPT: error: resource android:attr/ttcIndex not found.

  error: failed linking references.
  Command: C:\Users\emami\.gradle\caches\transforms-1\files-1.1\aapt2-3.2.1-4818971-windows.jar\8e7abbb87897c27c7928ae79da9182a2\aapt2-3.2.1-4818971-windows\aapt2.exe link -I\
          C:\sdk\platforms\android-27\android.jar\
          --manifest\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\merged_manifests\debug\processDebugManifest\merged\AndroidManifest.xml\
          -o\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\processed_res\debug\processDebugResources\out\resources-debug.ap_\
          -R\
          @C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\incremental\processDebugResources\resources-list-for-resources-debug.ap_.txt\
          --auto-add-overlay\
          --java\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\generated\not_namespaced_r_class_sources\debug\processDebugResources\r\
          --custom-package\
          com.example.flutterapp\
          -0\
          apk\
          --output-text-symbols\
          C:\Users\emami\AndroidStudioProjects\flutter_app\build\app\intermediates\symbols\debug\R.txt\
          --no-version-vectors
  Daemon:  AAPT2 aapt2-3.2.1-4818971-windows Daemon #0

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 10s
Finished with error: Gradle task assembleDebug failed with exit code 1

Moje trzepocze SDK następuje:
sdk: ">=2.0.0-dev.68.0 <3.0.0"
Jaki jest problem i jak mogę to naprawić?
Chyba może być z powodu konfliktu z moim trzepotą SDK i wersja {X1}}.

0
Mohsen Emami 20 luty 2019, 09:45

2 odpowiedzi

Najlepsza odpowiedź

Problem był dokładnie z powodu wersji Niekompatybilność flutter sdk i {x0}} biblioteka, zmieniłem go do local_auth: 0.3.0 i błąd zniknął.

1
Mohsen Emami 20 luty 2019, 11:10

Niech MainActivity dziedziczy FlutterFragmentActivity i dodaj pakiet support-v4 do build.gradle lub użyj androidx. Może odnosić się do Przykład

0
FingerArt 12 lipiec 2019, 11:43