Udało mi się wykonać aplikację Pyramid 1.2 WSGI uruchomić w programie SDK App Google App SDK 1.7. Jednak mój obecny projekt wykorzystuje kilka nowych funkcji Pyramid 1.3 i utknąłem w wersji WebOB. Oto komunikat o błędzie:

VersionConflict: (WebOb 1.1.1 (/home/matt/Python/google_appengine/lib/webob_1_1_1), Requirement.parse('WebOb>=1.2dev')

Czy jest coś, co mogę zrobić lub muszę czekać na nowe wydanie gry?

3
Matt234 10 sierpień 2012, 11:14

3 odpowiedzi

Najlepsza odpowiedź

Dość niezawodny sposób zarządzania aplikacją piramidy i zależności od appengine jest za pośrednictwem piramid_appeckine biblioteka, która Generuje projekt szkieletu, który używa Buildout.

Zrzeczenie się: Napisałem to w ramach Pyramid Sprint w Pycon w tym roku.

2
Tom Willis 15 sierpień 2012, 17:55

Zawsze możesz łączyć własną wersję WebOB za pomocą aplikacji:

W katalogu aplikacji:

wget http://pypi.python.org/packages/source/W/WebOb/WebOb-1.2.2.zip
unzip WebOb-1.2.2.zip
mv WebOb-1.2.2/webob .
rm -fR WebOb-1.2.2*

I przeanalizuj swoją aplikację.

0
proppy 10 sierpień 2012, 14:36

Skończyło się na modyfikację lib / Python2.7 / Pakiety serwisowe / Pyramid-1.3.2-Py2.7.Egg / Egg-Info / wymaga.txt w moim Virtualenv. Zmieniłem WebOB> = 1.2DEV dla WebOB> = 1.1.1 i działało!

0
Matt234 10 sierpień 2012, 17:58