Wersje:

Django                   2.2.10
django-hosts             4.0

Zainstalowałem Django_hosts z powodzeniem jako na tę dokumentację .

Mogę pomyślnie uzyskać dostęp do stron takich jak https://blog.mysite.com

Jednak adresy URL na stronie są nie rozwiązane prawidłowo. Podążałem za przykładem pokazanym w Django_hosts Oficjalna dokumentacja.

Tak wygląda moja konfiguracja:

Mysite / urls.py.

# imports etc. truncated for brevity 
# ...

urlpatterns = [
    path('', include(('home.urls', 'home'), namespace='home')),   
    path('blog/', include('blog.urls', namespace="blog")),
    # ...
]

Strona główna / URLS.PY.

from django.urls import path
from django.conf.urls import include, url 

from .views import HomePageView, AboutView, TermsView, PrivacyView, \
                    sample, register, signin

app_name = 'home'

urlpatterns = [
    path('', HomePageView.as_view(), name='index'),
    path('about', AboutView.as_view(), name='about'),
    path('terms', TermsView.as_view(), name='terms'),
    path('privacy', PrivacyView.as_view(), name='privacy'),

    path('sample', sample),    
    path('register', register, name='register'),
    path('signin', signin, name='signin'),
]

Blog / szablony / index.html

                    <div class="container">
116                     <!-- Logo -->
117                     <a class="logo" href="{% host_url 'home' host 'www' %}" style="text-decoration: none; font-size: 250%;">
118                         <img src="/static/assets/img/logo.png">
119                         My Site
120                     </a>                    
121                     <!-- End Logo -->

[[Edytuj]]

Rzeczywiste demo jest Przesłano do GitHub

0
Homunculus Reticulli 22 październik 2020, 15:52

1 odpowiedź

Najlepsza odpowiedź

Poniżej tego, jak udało mi się rozwiązać problem

. mysite

  .. blog  # Blog app
     .. __init__.py
     .. urls.py

  .. home  # Home app
     .. __init__.py
     .. urls.py


  .. mysite

     .. urls
        .. __init__.py
        .. blog.py
        .. home.py

     .. settings.py

     .. hosts.py

W mysite/settings.py

[..]

ALLOWED_HOSTS = [
              'mysite.com',
         'blog.mysite.com',
]

[..]


MIDDLEWARE = [
    'django_hosts.middleware.HostsRequestMiddleware',  # django hosts

    [..]

    'django_hosts.middleware.HostsResponseMiddleware',  # django hosts
]

ROOT_URLCONF = 'mysite.urls.home'

# django-hosts
# https://django-hosts.readthedocs.io/en/latest/#settings

ROOT_HOSTCONF = 'mysite.hosts'

DEFAULT_HOST = 'www'  # HERE see hosts.py

PARENT_HOST = 'mysite.com'

# HOST_SCHEME = 'http'

# HOST_PORT = 8000

# HOST_SITE_TIMEOUT = 3600

[..]

W mysite/hosts.py

from django.conf import settings

from django_hosts import patterns, host


host_patterns = patterns('',

    # mysite.com
    host(r'^$', 'settings.ROOT_URLCONF', name='www'),  # see 'settings.py'

    # blog.mysite.com
    host(r'blog', 'mysite.urls.blog', name='blog'),
)

W mysite/urls/home.py

from django.conf import settings
from django.contrib import admin
from django.urls import path, include


urlpatterns = [
    path('',       include('home.urls', namespace='home')),

    path('admin/', admin.site.urls),  # Admin Area
]

[..]

W mysite/urls/blog.py

from django.urls import path, include


urlpatterns = [
    path('', include('apps.blog.urls', namespace='blog')),

]

[..]

W blog/templates/index.html

<div class="container">
    <!-- Logo -->
    
     <!-- HERE you don't need to specify host 'www' since it defaults to 'www' see settings.py -->
    <a class="logo" href="{% url 'home:index' %}" style="text-decoration: none; font-size: 250%;">
        <img src="/static/assets/img/logo.png">
        My Site
    </a>
    <!-- End Logo -->

2
cizario 22 październik 2020, 17:14