Próbuję zaktualizować z " Apollo-Server": "^ 2.9.4" i "apollo-serwer-ekspres" : "^ 2.9.4" do < Strong> 2.12.0 Wersja W maszynach, podczas procesu kompilacji aplikacji otrzymuję błąd następujący:

Node_modules / Apollo-Server-Express / Node_modules / Apollo-Server-Core / Dist / Plugin / index.d.ts: 1: 13

Błąd TS1005: "=" oczekiwany.

1 Importuj Typ {Apolloserverplugin} z "Apollo-server-Plugin-Base";

enter image description here

Nie znalazłem jeszcze poprawki, usunięłem folder Node_modules i pakiet-Lock.json, ale wciąż nie działa.

Miło byłoby mieć pomoc ....

tsconfig.json


{
  "compilerOptions": {
    "target": "es5",
    "moduleResolution": "node",
    "strict": true,
    "esModuleInterop": true,
    "skipLibCheck": true,
    "outDir": "./dist",
    "declaration": true
  },
  "include": [
    "src/**/*"
  ],
  "exclude": [
    "node_modules",
    "**/*.spec.ts",
    "**/*.test.ts"

  ]

}



package.json

"dependencies": {
    "@apollo/federation": "^0.10.2",
    "@types/bluebird": "^3.5.27",
    "@types/cookie-parser": "^1.4.2",
    "@types/jest": "^24.0.19",
    "@types/mysql": "^2.15.7",
    "@types/nanoid": "^2.0.0",
    "@types/node": "^14.10.1",
    "@types/umzug": "^2.2.2",
    "@types/validator": "^10.11.3",
    "apollo-cache-control": "^0.10.0",
    "apollo-cache-inmemory": "^1.6.6",
    "apollo-client": "^2.6.4",
    "apollo-datasource-rest": "^0.6.1",
    "apollo-link": "^1.2.12",
    "apollo-link-context": "^1.0.20",
    "apollo-link-http": "^1.5.17",
    "apollo-link-rest": "^0.7.3",
    "apollo-link-schema": "^1.2.3",
    "apollo-server": "^2.12.0",
    "apollo-server-express": "^2.12.0",
    "apollo-server-plugin-response-cache": "^0.3.1",
    "apollo-server-testing": "^2.9.0",
    "axios": "^0.19.2",
    "cookie-parser": "^1.4.4",
    "cron": "^1.7.2",
    "elastic-apm-node": "^3.3.0",
    "express": "^4.17.1",
    "express-graphql": "^0.9.0",
    "graphql": "^14.5.8",
    "graphql-import": "^0.7.1",
    "graphql-schema-linter": "^0.2.1",
    "jsonwebtoken": "^8.5.1",
    "jwk-to-pem": "^2.0.3",
    "kafka-node": "^4.1.3",
    "link": "^0.1.5",
    "log4js": "^5.0.0",
    "mysql2": "^1.7.0",
    "nanoid": "^3.1.7",
    "node": "^14.5.0",
    "node-cache": "^5.1.1",
    "node-fetch": "^2.6.0",
    "promise-retry": "^1.1.1",
    "rimraf": "^3.0.0",
    "save": "^2.4.0",
    "sequelize": "^5.19.5",
    "sequelize-cli": "^5.5.1",
    "soap": "^0.30.0",
    "ts-jest": "^24.1.0",
    "typescript": "^3.6.3",
    "umzug": "^2.2.0"
  },
  "devDependencies": {
    "@types/graphql": "^14.5.0",
    "graphql-tag": "^2.10.1",
    "graphql-tools": "^4.0.5",
    "jest": "^24.8.0",
    "jest-cli": "^24.8.0"
  },
  "jest": {
    "testEnvironment": "node",
    "testPathIgnorePatterns": [
      "/node_modules/",
      "/dist/"
    ],

2
Andres 22 październik 2020, 05:47

2 odpowiedzi

Najlepsza odpowiedź

Składnia import type używana w Apollo-Server-Core nie jest obsługiwana przez wersję maszynopistu, której używasz (V3.6). Ta składnia stała się dostępna w wersji V3.8. HTTPS: //www.typescriptLang.org/docs/handbook/release-notes/typescript-3-8.Html#type-only-imports-In-export.

Zaktualizuj maszynopis i błąd zniknie

2
Tim de Wolf 28 październik 2020, 11:53

Starałem się również do tego samego rodzaju błędu w imporcie maszynopis, próbowałem różnych wartości w lib , Modułach i Cel w pliku tsconfig.json, ale nie z nich działało, nigdy nie chciałem zmienić plik node_modules , ale w końcu musiałem (smutny buźkę), zmiana wykonałem w moim index.d.ts był
.. import type { DocumentNode } from 'graphql/language/ast';

. import { DocumentNode } from 'graphql/language/ast';
.. także ta wartość w lib w tsconfig.json również pomogła
.. "lib": ["es6", "dom", "esnext", "esnext.asynciterable"],

0
Awais Nasir 11 luty 2021, 08:00