Poszedłem kursem reagującym. Następny krok został użyty npm run eject, dzięki czemu można użyć modułów CSS.

Od wyrzucania nie mogę używać NPM Start. Strona nie sporządza się. Pojawia się długa lista ostrzeżeń (co faktycznie wydają się być z plików konfiguracyjnych WebPack).

Stworzyłem plik .eSlininignore dla tych i innych plików:

./reactNotes.jsx
./nodeTest.js
./config
./scripts

Ale ani mój edytor kodu (kod VS) lub webpack zdaje się zauważać ten plik. EsLint jest instalowany na całym świecie.

Zbadałem również konfigurację WebPack dla EsLint z opcjami, takimi jak wykluczyć:

  {
    test: /\.(js|jsx|mjs)$/,
    enforce: 'pre',
    use: [
      {
        options: {
          formatter: eslintFormatter,
          eslintPath: require.resolve('eslint'),
        },
        loader: require.resolve('eslint-loader'),
      },
    ],
    include: paths.appSrc,
    exclude: /config/
  }

Kod VS ma EsLint włączony w moich ustawieniach użytkownika.

Jak mogę skonfigurować webpack (a może nawet VS Code), aby zignorować katalogi i pliki?

Aktualizacja: tutaj jest .eSlintrc:

{
    "parser": "babel-eslint",
    "extends": "react-app",
    "plugins": [
        "react",
        "jsx-a11y",
        "import"
    ],
    "rules": {
        "linebreak-style": [
            "error",
            "windows"
        ],
        "indent": [
            "error",
            4
        ],
        "react/prop-types": 0,
        "react/jsx-indent": 0,
        "jsx-a11y/click-events-have-key-events": 0,
        "jsx-a11y/no-noninteractive-element-interactions": 0,
        "max-len": 0,
        "arrow-body-style": 0,
        "react/jsx-indent-props": 0,
        "react/no-unescaped-entities": 0,
        "react/jsx-no-bind": 0,
        "arrow-parens": 0,
        "react/no-array-index-key": 0
    }
}

Również instalacja NPM i ponowna uruchomienie przeglądarki nie działa.

browser errors

3
cham 4 czerwiec 2018, 04:06

3 odpowiedzi

Najlepsza odpowiedź

Odpowiedź Lighky naprawia kod VS.

Aby naprawić kompilację dodać w nieruchomości Wyklucz do WebPack.Config, który zawiera plik pracownika usług:

  {
    test: /\.(js|jsx|mjs)$/,
    enforce: 'pre',
    use: [
      {
        options: {
          formatter: eslintFormatter,
          eslintPath: require.resolve('eslint'),
          emitError: false,
        },
        loader: require.resolve('eslint-loader'),
      },
    ],
    include: paths.appSrc,
    exclude: /(config|node_modules|registerServiceWorker.js|nodeTest.js|reactNotes.jsx|webpack.config)/,
  }
0
cham 4 czerwiec 2018, 02:53

W swoim Eslininignore spróbuj zmienić

./config
./scripts

Do

config/
scripts/

W doktorze EsLint, statystyki IT:

Ignoruj wzory zachowują się zgodnie z specyfikacją .giTignore

Możesz znaleźć pełną specyfikację Oto

1
loveky 4 czerwiec 2018, 02:42

Create-React-APP wykorzystuje EsLint wewnętrznie do podporządkowania i nie działa, gdy kontrola ESLINN rzuca błąd, jeśli skonfigurowałeś EsLint oddzielnie (za pomocą konfiguracji. skonfigurowano. Problemem, który stawiłem, że podczas korzystania z debugera nie zaczyna się i rzuca wyjątkiem no-debugger. Stworzyłem oddzielną konfigurację ESLINN i nazwałem go test.eslintrc.js, a w moim package.json zrobiłem: "lint": "eslint src -c test.eslintrc.js", Wewnątrz "scripts" Tag

Możesz także użyć katalogów

1
Sameerk129 28 grudzień 2018, 06:47