Lavel uruchamia Zwolnienie zabezpieczające. Używam Lavel 6.18.12 i próbując zaktualizować do 6.18.29, więc kiedy zaktualizowałem mój plik kompozytora.json z "laravel/framework": "^6.18.29" Wykonuję ten błąd:

enter image description here

Czytanie o tym w stackoverflow Widzę, że ludzie, którzy zainstalowali doktrynę / zapakowanie na 1.4 naprawić swoje problemy. Zrobiłem to: composer install doctrine/inflector:1.4 i spróbuj ponownie zaktualizować Laval z {x1}}, ale wydarzyło się nowy błąd:

enter image description here

Je zainstalowałem również symfony / polifild-php7.3 (używam PHP 7.3). Zrobiłem, że mogę zaktualizować wersję Lavel, ale zawsze otrzymuję ten błąd 401, gdy próbuję uzyskać moje dane API:

enter image description here

Dzieje się tak ze wszystkimi moimi prośbami API. Wygląda na coś o auth: API Middleware, ale nie jestem pewien, dlaczego. Mój użytkownik jest zalogowany w sieci, mogę używać rzeczy auth (), ale API wygląda jak użytkownik nie jest uwierzytelniony. Przed tą aktualizacją wszystko działało.

PS: Nie używam paszportu, ale używam iskry obok mojego projektu.

0
itepifanio 29 lipiec 2020, 21:47

1 odpowiedź

Najlepsza odpowiedź

Jak myślałem, ta łatka Lavel musi zostać rozwiązana także w iskry, więc teraz aktualizuję najnowszą wersję. Więcej informacji: Taylor Odpowiedz

0
itepifanio 29 lipiec 2020, 21:23