Dostaję to ostrzeżenie

(Węzeł: 4692) AmprecationWarning : Chunk.modules jest przestarzały. Zamiast tego użyj Chunk.getNumberOfModules/mapModules/forEachModule/containsModule

Po uaktualnieniu z webpack v2.6.1 do v3. W v2xx działa dobrze, ale v3 daje mi ten błąd.

Nie wiem, który pakiet powodujący problem. Pomocne mogą być każde odniesienia lub link.

enter image description here

enter image description here

Mój plik package.json:

{
  "name": "app",
  "version": "1.0.0",
  "description": "app",
  "scripts": {
    "start": "webpack-dev-server --hot --inline --progress --colors  --port 2000"
  },
  "license": "MIT",
  "dependencies": {
    "@angular/animations": "~4.2.4",
    "@angular/common": "~4.2.4",
    "@angular/compiler": "~4.2.4",
    "@angular/core": "~4.2.4",
    "@angular/forms": "~4.2.4",
    "@angular/http": "~4.2.4",
    "@angular/material": "~2.0.0-beta.7",
    "@angular/platform-browser": "~4.2.4",
    "@angular/platform-browser-dynamic": "~4.2.4",
    "@angular/router": "~4.2.4",
    "core-js": "~2.4.1",
    "hammerjs": "~2.0.8",
    "rxjs": "~5.4.1",
    "zone.js": "~0.8.12"
  },
  "devDependencies": {
    "@angular/compiler-cli": "~4.2.4",
    "@angular/platform-server": "~4.2.4",
    "@ngtools/webpack": "~1.4.1",
    "@types/jquery": "^2.0.43",
    "@types/node": "~8.0.0",
    "@types/typeahead": "~0.11.29",
    "angular2-router-loader": "~0.3.5",
    "angular2-template-loader": "~0.6.2",
    "awesome-typescript-loader": "~3.1.3",
    "chunk-manifest-webpack2-plugin": "~1.0.1",
    "compression-webpack-plugin": "~0.4.0",
    "css-loader": "~0.14.0",
    "extract-text-webpack-plugin": "^3.0.0-beta.3",
    "file-loader": "~0.11.2",
    "html-loader": "~0.4.5",
    "html-webpack-plugin": "~2.28.0",
    "imports-loader": "^0.7.1",
    "moment": "^2.18.1",
    "null-loader": "~0.1.1",
    "raw-loader": "~0.5.1",
    "rimraf": "~2.6.1",
    "split-by-name-webpack-plugin": "~0.0.3",
    "style-loader": "~0.18.2",
    "tslint": "~5.4.3",
    "typescript": "~2.3.4",
    "uglify-js": "^3.0.19",
    "uglify-loader": "~2.0.0",
    "uglifyjs-webpack-plugin": "^0.4.6",
    "webpack": "~3.0.0",
    "webpack-bundle-analyzer": "~2.8.2",
    "webpack-chunk-hash": "~0.4.0",
    "webpack-dev-server": "~2.5.0",
    "webpack-merge": "~4.1.0",
    "webpack-uglify-parallel": "~0.1.3"
  }
}
4
Robin 24 czerwiec 2017, 08:25

3 odpowiedzi

Najlepsza odpowiedź

Dostałem przestarzały ostrzeżenie w extract-text-webpack-plugin 3.0.0-beta.3. Po zaktualizowaniu ekstraktu-tekst-webpack-wtyczkę do v3.0.2, a następnie ten link AmodulesWarning Chunk.Modules w webpack 3.x, ostrzeżenie już nie ma, a WebPack V3XX działa bez żadnego błędu.

webpack

v3.8.1

Ekstrakt-tekst-Webpack-Plugin

v3.0.2

7
Robin 26 marzec 2018, 08:47

Zamienianie się z "WebPack-MD5-Hash": "0.0,5",

Do

"Webpack-Chunk-Hash": "0.5.0"

Naprawiono dla mnie ostrzeżenie. Nowy pakiet jest widelcem starego.

2
Ian Robertson 7 listopad 2017, 13:27

Wygląda na extract-text-webpack-plugin, zobasz pokoczny tutaj: https://github.com/webpack-Contrib/extract-text-webpack-plugin/issues/529.

3
robertklep 25 czerwiec 2017, 15:01