Przełączyłem się do jednej usługi aplikacji z dwoma gniazdami wdrażania do integracji i produkcji zamiast dwóch usług aplikacji działających na tym samym planie serwisowym aplikacji. Teraz zauważyłem, że od mojego ostatniego swapu (który zajęło ponad 7 minut), moje użycie procesora jest stale w 100%, co do tej pory nigdy nie wydarzyło się wcześniej, kiedy miałem dwie usługi App, a które tak naprawdę nie ma sensu, ponieważ aplikacja nic nie robi . Ponadto zatrzymałem wszystkie moje usługi App, a użytkowanie jest nadal na 100%. Moja szczelina integracyjna nie jest nawet w stanie zacząć, ponieważ zajmuje to zbyt długie.

Jak widać z wykresu, od czasu do czasu wykorzystywany do czasu, ale zawsze znowu się skończył. Teraz po prostu pozostaje

enter image description here

Program jest projektem Blazor Wasm z backendem rdzenia ASP.NET. Działa na planie S1. W tym czasie, w którym użycie procesora było tak wysoko, nikt nie był nawet aktywnie przy użyciu aplikacji, co czyni go nawet nieznajomym.

Co się tutaj dzieje i jak mogę to złagodzić?

0
NPadrutt 8 październik 2020, 03:02

1 odpowiedź

Najlepsza odpowiedź

Czy próbowałeś korzystać z Diagnostyka serwisu aplikacji do zobaczenia Jeśli da ci jakieś spostrzeżenia?

Jeśli korzystasz z interaktywnego trybu interfejsu, jest specjalnie opcja użytkowania procesora.

Azure Portal> Grupa zasobów> Twoja usługa aplikacji> Diagnozuj i rozwiązywanie problemów.

Istnieje również grupa Natywne rejestrowanie że możesz włączyć. Mieć podłączony wgląd aplikacji również nie boli.

0
Matt Stannett 8 październik 2020, 00:55