Niedawno zainstalowany 16.5 i Intellisense nigdy nie kończy się ładowania na dość prostym projekcie: Wprowadź obraz Opis tutaj

Muszę powiedzieć, że prowadzę Ryzen 3990 i SSD, tak bardzo zadzwoniłem, co nadal się dzieje. Jakieś podobne doświadczenie lub jak można ją naprawić? Zasadniczo, gdy próbuję zobaczyć metody klasy lub refaktora coś jest złamane, ponieważ Itellisense wciąż ładuje.

1
Fritjof Berggren 21 marzec 2020, 12:30

2 odpowiedzi

Najlepsza odpowiedź

Jakieś podobne doświadczenie lub jak można ją naprawić? Zasadniczo, gdy próbuję zobaczyć metody klasy lub refaktora coś jest złamane, ponieważ Itellisense wciąż ładuje.

Na podstawie twojego opisu jest to dość dziwne zachowanie i po mojej stronie (Visual Studio Community 16.5.0), działa dobrze i nie pokazuje loading intellisense forever. (W razie potrzeby podaj więcej szczegółowych informacji)

Myślę więc, że istnieją pewne problemy ze środowiskiem VS, spróbuj tych sugestii:

Sugestia

1) Jeśli twój projekt jest tworzony przez inną wersję poprzednią VS, zamknij instancję vs, Usuń {x0}} Hidden folder, bin, obj folder, a następnie uruchom ponownie projekt.

Poza tym spróbuj stworzyć nowy pusty projekt i przetestować, czy to nadal dzieje się.

2) Usuń dowolne buzery komponentów vs pod C:\Users\xxxx\AppData\Local\Microsoft\VisualStudio\16.0_xxxx\ComponentModelCache

3) Spróbuj użyć Devenv / Safemode, aby uruchomić vs, a następnie otwórz projekt lub wyłącz wszystkie rozszerzenia innych firm w menu Manage Extensions, aby przetestować, czy takie zachowanie jest spowodowane przez konkretne rozszerzenie. I pewne rozszerzenia innych firm prawdopodobnie zakłócają wykonanie zadań w tle VS, powodując przeciążenie.

4) Spróbuj Wykonaj poprawkę w studiu Visual, aby sprawdzić, czy vs jest uszkodzony.

1
Perry Qian-MSFT 23 marzec 2020, 07:31

Miałem podobne doświadczenie, wystarczy uruchomić studio wizualne raz z prawami administratora, wydaje się go naprawić.

0
BenV136 9 marzec 2021, 20:50