AZ COSMOSDB Mongodb Collection Create -G -a -D -N --idx @ indexes.json

Uruchamianie polecenia w tym formacie daje błąd: Wdrożenie nie powiodło się. ID korelacji: ..... Definicja indeksu nie zawiera specyfikacji indeksu "_id".

My indeksy.Json zawartość pliku jest taka jak pokazana pod spodem:

[
   { "_id": 1 },
   {
     "key": 
        {"keys":["$**"]},
           "options":{"Wildcard":true}
    }
]
0
Omesh Kumar Yadav 19 kwiecień 2021, 11:46

1 odpowiedź

Najlepsza odpowiedź

Spróbuj zamiast tego JSON.

"indexes": [
    {
        "key": {
            "keys": [
                "_id"
            ]
        }
    },
    {
        "key": {
            "keys": [
                "$**"
            ]
        }
    }
]
0
Mark Brown 19 kwiecień 2021, 17:55