Mam następujące przykładowe dokumenty w Elasticsearch

[
  {
    "_index": "beatbox-2018.11.19",
    "_source": {
      "connection": "10",
      "user": "op-dashboard",
      "key": "monolith_connection_sniffer"
    }
  },
  {
    "_index": "beatbox-2018.11.19",
    "_source": {
      "connection": "10",
      "user": "op-dashboard",
      "key": "monolith_connection_sniffer"
    }
  }
]

Kiedy pytam o użytkownika, otrzymałem oczekiwany wynik.

curl -X GET \
  'http://127.0.0.1:9200/beatbox-2018.11.19/_search?q=user:op-dashboard'

W Grafanie:

Próbowałem dodać zapytanie ze zmienną dla pola użytkownik.

{   "find": "terms",   "field": "user" }

Ale otrzymałem stokenizowane wartości pola użytkownik.

`op`, `dashboard`

W tle następujący ładunek wysyła zapytanie

{
  "size": 0,
  "query": {
    "bool": {
      "filter": [
        {
          "query_string": {
            "analyze_wildcard": true,
            "query": "*"
          }
        }
      ]
    }
  },
  "aggs": {
    "1": {
      "terms": {
        "field": "user",
        "size": 500,
        "order": {
          "_term": "asc"
        }
      }
    }
  }
}

Zapytanie zwraca wynik tokenizowany. Jak mogę to zatrzymać?

Próbowałem już z następującym szablonem

{
  "index_patterns": [
    "beatbox*"
  ],
  "mappings": {
    "doc": 
      "properties": {
        "user": {
          "type": "text",
          "fielddata": true,
          "analyzer":"whitespace",
          "search_analyzer": "whitespace"
        }
      }
    }
  }
}

A także z analizatorem

{
  "index": {
    "analysis": {
      "default": {
        "analyzer": {
          "analyzer_keyword": {
            "tokenizer": "whitespace"
          }
        }
      }
    }
  }
}

Mapowanie dla indeksu:

{
   "beatbox-2018.11.19":{
      "mappings":{
         "doc":{
            "_all":{
               "enabled":false
            },
            "numeric_detection":true,
            "properties":{
               "connection":{
                  "type":"long"
               },
               "key":{
                  "type":"text",
                  "norms":false,
                  "index_options":"freqs"
               },
               "user":{
                  "type":"text",
                  "fielddata":true
               }
            }
         }
      }
   }
}

Jakaś pomoc?

0
Shahriar 19 listopad 2018, 09:47

1 odpowiedź

Najlepsza odpowiedź

Powinieneś Keyword Typ danych Elasticsearch zamiast text typu danych w polach user podczas agregacji.

1
safwan 19 listopad 2018, 12:49