Nie mogę zainstalować ssh2 w centos.

Używam apache2 i PHP 7.3

Używam poniższego polecenia i podam błąd jak poniżej

yum install gcc php-devel libssh2 libssh2-devel php-pear make
pecl install -f ssh2

Ale pokazuje mi poniżej błąd

No package php-devel available.
No package php-pear available.

Proszę powiedz mi, czego mi brakuje.

1
Niraj Savaliya 19 grudzień 2019, 09:15
Mniam zainstaluj gcc php-devel libssh2 libssh2-devel php-pear make czy to polecenie zostało wykonane pomyślnie?
 – 
Sachin Singh
20 grudzień 2019, 13:37

1 odpowiedź

W CentOS 7, co z włączeniem EPEL, a następnie yum install php-pecl-ssh2

EDYCJA: Wygląda na to, że CentOS 7 domyślnie zawiera PHP 5. Strona ssh2 (https://pecl.php.net/package/ssh2) mówi:

ssh2 1.0 i nowsze to tylko PHP 7. Aby zainstalować wersję kompatybilną z PHP 5, możesz uruchomić 'pecl install ssh2-0.13'

1
thafuzziest 21 grudzień 2019, 10:24
1
Używam php 7.3
 – 
Niraj Savaliya
23 grudzień 2019, 14:00