Mam pewne trudności z ustawieniem prostego skrótu klawiszowego w Sublime Text 2, którego używam dopiero od kilku godzin.

Udało mi się zainstalować Podgląd Markdown i nauczyłem się, jak go wywołać w prostym pliku tekstowym Markdown. Moim kolejnym pragnieniem było ustawienie prostego powiązania klawiszy, aby wyświetlić podgląd przeglądarki bez konieczności przechodzenia przez Paletę poleceń, co uważam za nieco kłopotliwe.

Instrukcje pod powyższym linkiem są dość jasne i udało mi się zmodyfikować moje ustawienia użytkownika zgodnie z zaleceniami, aby wyglądały tak:

// Settings in here override those in "Default/Preferences.sublime-settings", and
// are overridden in turn by file type specific settings.
{
    "keys": ["alt+m"], 
        "command": "markdown_preview", 
        "args": 
            {
                "target": "browser"
            }
}

Jednak z jakiegoś powodu ALT-m nie wyświetla podglądu. Zamiast tego do mojego pliku tekstowego zostaje wstawiona grecka litera mu.

Założyłem, że dzieje się tak z powodu pewnych osobliwości związanych z klawiszem Option na Macu, więc eksperymentowałem z próbą powiązania go z innym klawiszem, takim jak „f7”, ale to też nie działa.

Czy ktoś może pomyśleć o jakichś problemach związanych z przypisaniami klawiszy dla Sublime Text 2 na MacOS X, które mógłbym przeoczyć?

2
pohl 19 październik 2012, 04:14

2 odpowiedzi

Najlepsza odpowiedź

Przypisania klawiszy użytkownika są zdefiniowane w pliku .sublime-keymap, myślę, że jesteś w .sublime-settings file. Po prostu umieść go w odpowiednim pliku i powinno działać. Pracuję w systemie Windows, więc nie jestem pewien, czy jest identyczny w przypadku komputerów Mac, ale mogę uzyskać dostęp do pliku z menu Preferencje (Key Bindings - User).

2
bananafish 19 październik 2012, 04:39

Chciałbym coś dodać, wysublimowany tekst2 i os x 10,8

Sprawdź poniższy obrazek, przejdź do Menu tekstu wysublimowanego 2, Sublime Text 2 -> Preference -> Key Binds Default - a następnie w pliku edytuj według potrzeb,

enter image description here

1
staticor 19 czerwiec 2013, 13:05