Używam xcode4.2, chcę, aby moja aplikacja obsługiwała również ios4 i ios5, czy ktoś może mnie poprowadzić, jak mogę się upewnić, że moja aplikacja będzie obsługiwać oba i jak mogę przetestować moją aplikację w symulatorze (dla ios4 i ios5)

0
Abhishek Sahay 8 marzec 2012, 08:28

2 odpowiedzi

Najlepsza odpowiedź

W widoku podsumowania celu (wybierz ikonę projektu u góry widoku Nawigatora, wybierz cel w widoku edytora, wybierz kartę Podsumowanie), ustaw „Cel wdrożenia” na 4.0, a następnie stwórz swój kod tak, aby nie był używany dowolny interfejs API nowszy niż 4.0 lub warunkowo go używasz w oparciu o zainstalowaną wersję systemu operacyjnego.

0
kamprath 8 marzec 2012, 08:38

ABSOLUTNIE BEZ SYMULATORA. Symulator SZEROKO różni się od prawdziwego urządzenia z systemem iOS. Polecam kupić coś taniego w serwisie eBay i załadować do niego iOS 4.x, jeśli naprawdę chcesz znaleźć jakiś poważny problem. Mówiąc z doświadczenia, wypuściliśmy wersję z błędami, która miała być drobną poprawką (ARC+Leaves= Epic Fail), tak czy inaczej, ponieważ nie testowaliśmy na fizycznym urządzeniu, wysłaliśmy kompilację, która ulegała awarii podczas uruchamiania. TRZEBA przetestować zgodność na fizycznym urządzeniu.

1
CodaFi 8 marzec 2012, 08:39