Używam NPanday do kompilowania projektu c# w ramach kompaktowej platformy .NET 3.5. NPanday oczekuje, że System.Windows.Forms.DataGrid i Microsoft.Transactions.Bridge zostaną znalezione w kompaktowym frameworku, ale brakuje ich w mojej instalacji.

Na innym komputerze zauważyłem, że te 2 zespoły istnieją w .NET 2.0 compact. Czy powinienem je skopiować do mojego katalogu 3.5? Gdzie zwykle znajdują się te zespoły?

2
takteek 9 czerwiec 2011, 01:10
Nie sądzę, aby Microsoft.Transactions.Bridge lub DataGrid były obsługiwane w Compact Framework, sprawdź MSDN, aby zobaczyć, czy są w obsługiwanych wersjach.
 – 
Mike Miller
9 czerwiec 2011, 01:13
Miller Spojrzałem na klasa DataGrid z wersją frameworka = 3.5 i napisem „.NET Compact Framework. Obsługiwane w: 3.5, 2.0, 1.0”, więc wydaje się, że powinno tam być. Nie mogę znaleźć niczego, co mówiłoby, że Microsoft.Transactions.Bridge jest obsługiwany.
 – 
takteek
9 czerwiec 2011, 01:45
Czy to nadal problem? Może to łatwe do naprawienia w NPaday...?
 – 
Lars Corneliussen
10 listopad 2011, 01:27

2 odpowiedzi

Najlepsza odpowiedź

Przenieśli System.Windows.Forms.DataGrid z powrotem do głównych zestawów .NET 3.5, więc po prostu usuń szacunek do System.Windows.Forms.DataGrid.dll, a powinien on się dobrze skompilować.

0
Daniel O 30 lipiec 2014, 16:22