Moja aplikacja na Androida jest teraz wersja 3. Przywróciłem go do kodu wersji 2. rzuca błąd mówiąc "Wykryto obniżenie: Kod wersji aktualizacji 2 jest starszy niż bieżący 3" w dziennikach. Mając na uwadze, że ulepszenie od 2 do 3 zakończy się sukcesem.

Na ekranie pokazano jako "parsowanie błędów pakietu" i instalację nie powiodło się.

Czy mogę obniżyć aplikację?

Każda pomoc byłaby bardzo mile widziana.

0
Soujanya Divi 16 luty 2017, 13:08

2 odpowiedzi

Najlepsza odpowiedź

Jeśli masz już zainstalowaną aplikację z większym numerem wersji, ten, który obecnie próbujesz zainstalować, otrzymasz błąd. To powiedziane, ponieważ nie publikowałeś aplikacji, możesz po prostu odinstalować aplikację z telefonu i zainstalować włączoną wersję.

Edytuj: Jeśli już opublikowałeś aplikację poza PlayStore (ta sama reguła ma zastosowanie do PlayStore) powinieneś publikować aplikacje z większym numerem wersji.

0
Goran 16 luty 2017, 10:19

Dezaktywuj wersję 3.0, aktywuj wersję 2.0.

Nie wiem, czy to będzie obniżyć każdy, kto został już zaktualizowany do 3.0, ale powstrzyma kogoś, kto nie uaktualnił z pobrania 2.0.

Jeśli chcesz mieć pewność, że wszyscy wracają do kodu z wersji 2.0, może być konieczne ponowne rozpowszechnianie 2.0 jako 4.0, co gwarantuje ludzi na 3.0, może "uaktualnić" do starej bazy kodu.

0
Amit Kumar Verma 16 luty 2017, 10:15