Illuminate\Database\QueryException  : SQLSTATE[HY000] [2002] Connection 
refused (SQL: select * from information_schema.tables where 
table_schema = QualityBooks and table_name = migrations)

at     /Users/lakhanpals/.bitnami/stackman/machines/xampp/volumes/root/htdocs/lv-bookstoreAS/vendor/laravel/framework/src/Illuminate/Database/Connection.php:664
    660|         // If an exception occurs when attempting to run a 
query, we'll format the error
661|         // message to include the bindings with SQL, which will make this exception a
662|         // lot more helpful to the developer instead of just the database's errors.
663|         catch (Exception $e) {
> 664|             throw new QueryException(
665|                 $query, $this->prepareBindings($bindings), $e
666|             );
667|         }
668| 

 Exception trace:

 1   PDOException::("SQLSTATE[HY000] [2002] Connection refused")
  /Users/lakhanpals/.bitnami/stackman/machines/xampp/volumes/root/htdocs/lv- bookstoreAS/vendor/laravel/framework/src/Illuminate/Database/Connectors/Connector.php:70

2   PDO::__construct("mysql:host=127.0.0.1;port=3306;dbname=QualityBooks", "root", "", [])
  /Users/lakhanpals/.bitnami/stackman/machines/xampp/volumes/root/htdocs/lv-bookstoreAS/vendor/laravel/framework/src/Illuminate/Database/Connectors/Connector.php:70

Przeszedłem przez tak wiele postów, ale nie jestem pewien, dlaczego moja „migracja artisan php” nie działa i otrzymuję ten błąd. Przeszedłem przez tak wiele postów na stosie, ale to nie działa, zrestartowałem również mojego Maca. brak szczęścia

Plik konfiguracyjny bazy danych

'connections' => [

    'sqlite' => [
        'driver' => 'sqlite',
        'database' => env('DB_DATABASE', database_path('database.sqlite')),
        'prefix' => '',
        'foreign_key_constraints' => env('DB_FOREIGN_KEYS', true),
    ],

    'mysql' => [
        'driver' => 'mysql',
        'url' => env('DATABASE_URL'),
        'host' => env('DB_HOST', '127.0.0.1'),
        'port' => env('DB_PORT', '3306'),
        'database' => env('DB_DATABASE', 'forge'),
        'username' => env('DB_USERNAME', 'forge'),
        'password' => env('DB_PASSWORD', ''),
        'unix_socket' => env('DB_SOCKET', ''),
        'charset' => 'utf8mb4',
        'collation' => 'utf8mb4_unicode_ci',
        'prefix' => '',
        'prefix_indexes' => true,
        'strict' => true,
        'engine' => null,
        'options' => extension_loaded('pdo_mysql') ? array_filter([
            PDO::MYSQL_ATTR_SSL_CA => env('MYSQL_ATTR_SSL_CA'),
        ]) : [],
    ],

Plik env

APP_NAME=Laravel
APP_ENV=local
APP_KEY=base64:Gj0+OwDiMt7ocVTD4f8UJaj77oWw7oGz2HGh8LFBLs0=
APP_DEBUG=true
APP_URL=http://localhost

LOG_CHANNEL=stack

DB_CONNECTION=mysql
DB_HOST=127.0.0.1
DB_PORT=3306
DB_DATABASE=QualityBooks
DB_USERNAME=root
DB_PASSWORD=

Uprawnienia bazy danych phpmyadmin.wprowadź opis obrazu tutaj

1
SEO Specialist 20 listopad 2019, 12:07
Czy możesz podać połączenie konfiguracji bazy danych
 – 
Dmitry
20 listopad 2019, 12:10
Proszę użyć zakodowanych pól podświetlenia, aby oddzielić się od tekstów pisanych. Recenzentom i potencjalnym respondentom byłoby łatwiej przeczytać.
 – 
ShocKwav3_
20 listopad 2019, 12:10
Sprawdź, czy plik .env jest w porządku. Następnie ponownie uruchom serwer xampp lub artisan po zmianie pliku .env
 – 
hemant
20 listopad 2019, 12:12
Upewnij się, że użytkownik bazy danych ma dostęp do wszystkich tabel w domenie @ 127.0.0.1. Możesz spróbować zmienić 127.0.0.1 na localhost w swoim pliku .env.
 – 
KFoobar
20 listopad 2019, 12:13
Przeszedłem przez tak wiele pytań i odpowiedzi i wypróbowałem wszystkie metody, nawet zrestartowałem mojego Maca, nadal nie działał, nawet próbowałem wyczyścić pamięć podręczną i konfigurację
 – 
SEO Specialist
20 listopad 2019, 12:17

1 odpowiedź

DB_HOST używa localhost

  'mysql' => [
            'driver'    => 'mysql',
            'host'      => env('DB_HOST', 'localhost'),
            'database'  => env('DB_DATABASE', 'forge'),
            'username'  => env('DB_USERNAME', 'forge'),
            'password'  => env('DB_PASSWORD', ''),
            'charset'   => 'utf8',
            'collation' => 'utf8_unicode_ci',
            'prefix'    => '',
            'strict'    => false,
            'engine'    => null,
        ],

następnie uruchom to polecenie

php artisan config:cache
php artisan config:clear
0
Vikas Katariya 20 listopad 2019, 12:59