Nie mogę zainstalować żadnych modułów Pythona, które wymagają Pythona 2.7 lub nowszego. Odinstalowałem wszystko, na co pozwalał mi Mac, a co było związane z Pythonem 2 i uruchamiam wszystko na Pythonie 3. Jestem kompletnie zagubiony. Jestem na komputerze Mac i za każdym razem, gdy próbuję zainstalować moduł (jak praw), pojawia się to.

Użyłem polecenia

pip install praw
Collecting praw
  Using cached https://files.pythonhosted.org/packages/41/89/94c1ec81a05536e2c2a1dc2e8f5402c8ad65963f28948bf41c64621e238b/praw-6.5.0-py2-none-any.whl
ERROR: Package 'praw' requires a different Python: 2.7.16 not in '>=3.5' ```
1
Malachi Noel 6 marzec 2020, 02:10

2 odpowiedzi

Najlepsza odpowiedź

Witamy w Stack Overflow Malachi! Wydaje mi się, że szukasz polecenia pip3 (pip3 install praw), aby zainstalować pakiety Pythona 3 przez pip. Jeśli otworzysz terminal i wpiszesz man pip, aby uzyskać stronę podręcznika, pojawi się wiersz, który mówi:

pip to polecenie używane podczas instalowania pakietów dla języka Python 2, a pip3 to polecenie używane podczas instalowania pakietów dla języka Python 3.

1
scoutchorton 5 marzec 2020, 23:27

Wygląda na to, że najnowsza wersja praw wymaga Pythona 3.5 lub nowszego.

Ostatnia wersja obsługująca Python 2.7 to praw 5.4.0. Jeśli nadal używasz Pythona 2.7 i potrzebujesz tego pakietu, spróbuj uruchomić

pip install praw==5.4.0

Jeśli używasz Pythona 3.x, sprawdź, czy używasz właściwej wersji pip. Jeśli masz w swoim systemie zainstalowany zarówno Python 2, jak i Python 3, prawdopodobnie będziesz musiał zainstalować pakiety dla całego systemu, używając pip3 zamiast tego, jeśli pip. W takim przypadku spróbuj uruchomić

pip3 install praw

Alternatywnie, jeśli celujesz w konkretnego interpretera Pythona (np. python3.7, python3.8 itp.) I chcesz mieć pewność, że używasz prawidłowego pip pliku wykonywalnego dla swojego interpretera, można uruchomić pip jako pakiet Pythona za pośrednictwem

python3 -m pip <args> 

Gdzie python3 można zastąpić dowolną ścieżką interpretera.

1
Brian 5 marzec 2020, 23:29